Phones Pro issues
Incident Report for ServiceTitan
Resolved
This incident has been resolved.
Posted Aug 07, 2023 - 14:05 PDT
Monitoring
Our third party vendor believes that they have fixed the underlying cause and are currently monitoring for further issues. We will update the status page here once resolution is confirmed or additional information becomes available. Thank you for your patience!
Posted Aug 07, 2023 - 12:24 PDT
Identified
Our engineers have identified the cause to be stemming from a third party telecom vendor, and are waiting on a resolution. We will update the status page here as soon as more information becomes available. Thank you for your patience!
Posted Aug 07, 2023 - 12:17 PDT
Investigating
We are currently experiencing issues with Phones Pro, so some ServiceTitan users may be unable to make outbound calls. Our engineers are currently investigating the cause. We will update the status page here as soon as more information becomes available. Thank you for your patience!
Posted Aug 07, 2023 - 11:49 PDT
This incident affected: Phone Integration (Phones Pro).