Mobile Application - Issues with syncing and jobs not appearing
Incident Report for ServiceTitan
Resolved
This incident has been resolved.
Posted Nov 10, 2022 - 13:18 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 10, 2022 - 12:57 PST
Update
We are continuing to work on a fix for this issue.
Posted Nov 10, 2022 - 12:41 PST
Update
We are continuing to work on a fix for this issue.
Posted Nov 10, 2022 - 11:53 PST
Identified
We are currently experiencing issues with our Mobile Application, so some ServiceTitan users may be unable to sync and/or see their jobs. Our engineers have identified the cause and are working on a resolution. We will update the status page here as soon as more information becomes available. Thank you for your patience!
Posted Nov 10, 2022 - 11:21 PST
This incident affected: Site Performance (Mobile App).