Login issues due to timezone misconfiguration
Incident Report for ServiceTitan
Resolved
This incident has been resolved.
Posted Jan 12, 2024 - 08:46 PST
Investigating
Some ServiceTitan users may be unable to login due to timezone misconfiguration. Our engineers are currently investigating the cause. If you encounter this issue, please report to our support team as they can apply a quick fix. We will update the status page here as soon as more information becomes available. Thank you for your patience!
Posted Jan 12, 2024 - 08:18 PST
This incident affected: Site Performance (Office).