Contact Center Pro Issues

Incident Report for ServiceTitan

Resolved

We have not seen any further issues with CCPRO and have confirmed the root cause to be resolved. We thank you for your patience with this matter. Please reach out to us in Support if you have additional issues and we will be happy to assist!
Posted Feb 25, 2026 - 09:06 PST

Update

We are continuing to monitor for any further issues.
Posted Feb 25, 2026 - 08:51 PST

Monitoring

Contact Center Pro has now recovered and We are currently monitoring the system for stability.Please turn off call continuity if you had enabled it: https://help.servicetitan.com/how-to/contact-center-pro-outage-standard-procedure

Users should also refresh their application status in the upper right corner.
Posted Feb 25, 2026 - 08:50 PST

Update

We are continuing to investigate this issue.
Posted Feb 25, 2026 - 08:17 PST

Investigating

Contact Center Pro is experiencing issues with inbound and outbound calls. We are urgently investigating and will update you when a fix has been identified.

In the meantime if you are experiencing issues with calls connecting, please use Call Continuity to keep your phones running smoothly as we work towards a resolution.

Ref: https://help.servicetitan.com/how-to/contact-center-pro-outage-standard-procedure
Posted Feb 25, 2026 - 07:54 PST
This incident affected: Contact Center Pro (Telephony Platform: Inbound Calling, Telephony Platform: Outbound Calling, Telephony Platform: Call Queues).