Virtual Voice Agents Performance Degradation

Incident Report for ServiceTitan

Resolved

The issue impacting Virtual Voice Agents has been fully resolved by our third-party provider, and all systems are operating normally. We sincerely apologize for the disruption and thank you for your patience today.
Posted Mar 20, 2026 - 08:26 PDT

Monitoring

We are moving to monitoring stage. The issue is mitigated.
Posted Mar 20, 2026 - 08:18 PDT

Identified

The issue has been identified. Our team is investigating it with the 3rd party. We appreciate your patience.
Posted Mar 20, 2026 - 08:09 PDT

Investigating

CCPro Customers may be experiencing an issue where Virtual Agents are dropping calls. Our team is actively engaged and investigating the issue.
Posted Mar 20, 2026 - 07:28 PDT
This incident affected: Contact Center Pro (Virtual Voice Agents).