Degraded Performance
Incident Report for ServiceTitan
Resolved
This incident has been resolved.
Posted Aug 30, 2022 - 08:58 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 30, 2022 - 08:32 PDT
Investigating
We are currently experiencing issues with degraded performance on our platform, so some ServiceTitan users may experience issues navigating ServiceTitan. We are currently investigating the cause and scope of this issue. Additionally, ServiceTitan is actively working to mitigate a known issue in Azure that has affected certain customers. For more details, see https://status.azure.com/en-us/status

We will update the status page here as soon as more information becomes available. Thank you for your patience!
Posted Aug 30, 2022 - 07:53 PDT
This incident affected: Site Performance (Office).