Schedule Engine - Job Issues
Incident Report for ServiceTitan
Resolved
This incident has been resolved.
Posted Apr 08, 2024 - 16:12 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 08, 2024 - 16:10 PDT
Investigating
We are currently experiencing issues with Schedule Engine, so some users may be unable to book jobs for ServiceTitan via Scheduling Pro, and ServiceChannel integration functions may not work. Our engineers are currently investigating the cause, as it is stemming from our performance issues. We will update the status page here as soon as more information becomes available. Thank you for your patience!
Posted Apr 08, 2024 - 14:14 PDT
This incident affected: Schedule Engine.