Technicians are not able to view Jobs
Incident Report for ServiceTitan
Resolved
We have not seen any further issues with the mobile application and have confirmed the root cause to be resolved. We thank you for your patience with this matter. Please reach out to us in Support if you have additional issues and we will be happy to assist!
Posted Aug 30, 2022 - 07:16 PDT
Monitoring
Regarding the recent issues with the mobile application, our engineers believe that they have fixed the underlying cause and are currently monitoring for further issues. We will update the status page here once a resolution is confirmed or additional information becomes available. Thank you for your patience!
Posted Aug 30, 2022 - 07:03 PDT
Identified
Regarding the recent issues with the mobile application, our engineers believe that they have fixed the underlying cause and are currently monitoring for further issues. We will update the status page here once the resolution is confirmed or additional information becomes available. Thank you for your patience!
Posted Aug 30, 2022 - 07:01 PDT
Investigating
We are currently experiencing issues with our mobile application, so some ServiceTitan users may be unable to view jobs on the mobile application. Our engineers are currently investigating the cause. Additionally, ServiceTitan is actively working to mitigate a known issue in Azure that has affected certain customers. For more details, see https://status.azure.com/en-us/status

We will update the status page here as soon as more information becomes available. Thank you for your patience!
Posted Aug 30, 2022 - 06:27 PDT
This incident affected: Site Performance (Mobile App).